Screenly Forum

Does Screenly work on the Raspberry Pi 4?

Thank you for the quick review. I will hold back for a little while to see if you can get it to run on boot. Please advice us if it is solved.

I gather from you that there are no options to have 2 instances of screenly running at this time, nor are they currently planned.

It’s not on the immediate roadmap, but it partially comes down to support in upstream software (such as omxplayer). Without that, we won’t be able to add support for it. That said, we will experiment with it, but we will commit to any timeline.

Here’s the ticket for adopting Raspberry Pi 4 support:

I have been able to get Screenly running reasonably well on a Pi4. It definitely was a challenge but it is doable.

@miosam. How were you able to do so? I’m new to RPi and ordered 4 RPi 4b’s for a video menu board project for a client and have not been able to get it to work. Just like @matrix above. I tried installing using the bash and it would not boot :disappointed:

Hi John,

It was a month ago and I recall that it was definitely a battle to get it to run.
Definitely not a rPi newbie task.

I believe I broke apart the bash installer script running it line by line in order to troubleshoot each step and see exactly where the failures lay.

I remember that I eventually had to disable all management of the wifi from within screenly and then setup wpa_supplicant manually.

Once I pulled out the screenly wifi management pieces from the script and met all the dependencies manually I could start up screenly manually just fine. I believe I might have auto-started it using rc.local instead of the installer’s method but that is probably just my old roots showing through. Hacking in rc.local is taboo of course but is an effective lazy-man’s method to get the job done.

I remember that I had to get creative and backport Buster manually on a few packages in order to meet some of the broken dependencies thereby really just breaking the system enough so it could function without grinding it all to a halt. It was a real Big Kludge the whole way but they do seem to be running just fine a month later. I doubt they could ever be updated though without pulling out my hair again. I only did it because I was buying time for an expected new version to come out that supported the rPi4.

One problem I never worked too hard to fix is that for some reason they like to recycle the wifi connection frequently after their daily reboots (Which I do with all rPi Screenly deployments) and when they get flaky like that they pull a new ip each time they cycle, sometimes every few minutes. A manual IP or reservation (in my case) fixed the problem. I am sure it can be fixed but it is something to think about, I was just happy they worked so I left well enough alone and got on with other things.

The first gen rPi4 has a defect in the boards which unless you are using the genuine rPi power supply is going to cause problems. I don’t know if I would really want to deploy such a kludged-up config and hardware bomb to a client site unless I was in real dire-straits and even then I would vlan them very far off the network to somewhere safe so they couldn’t become a security risk.

If you have a 3d printer and some smaller low voltage fans I would definitely print a case and install a fan to cool them, these rPi 4’s seem to run a lot hotter than the 3’s ever did.


Thanks. This is a tad disheartening, knowing all that had to be done to get it to work… :disappointed:

Version jumps are not always simple in Linux Land.

I’m sure they will come out with a 4 version one day.

If you are in a bad way I could give you a copy of my anonymized image to download it’s 32gb though.

No promises, no warranties.

Sadly, I’m likely going to be looking at other RPi solutions other than Screenly… Thanks everyone for your help. :+1:

I have the same problem too. Testing Screenplay OSE on a Raspberry 3B works…but I need more browser functionality and perhaps a 4K resolution. Now the Model 4 is waiting for a test but I could not get it running. The help on GitHub for generating a new image is not easy for me and so I don’t know if I should ditch to another solution.

Why a Rasp 4 ALPHA version is not available for download?

Could someone who understands Github slang please clarify us what goes on here regarding the Pi4 support:

What does the “we can close it without merging” and “Thus this PR makes no sense :)” verdict 4 days ago means in plain English?
Is the problem solved ? ie. Screenly OSE runs on Pi4? If yes why is it not ‘merged’? If not solved, then why is the case ‘closed’. If the issue is ‘solved’, where is, what is the solution so we can all implement it on our Pi4s?
Excuse me my ignorance if it is obvious, but it seems to me many of us can also not figure it out.

1 Like

@miosam, I would like a copy of your image that works with 4. It would make my life at work much easier. I’ve already talked it over with my boss and he pretty much told me to just make it work. We have Screenly on several monitors around our building that are running on 3’s, but this is our first time trying with a 4 and it’s driving me insane. If you’re offering it, I’ll take the chance.

My image quit working soon after posting this, very very odd.

I have been meaning to get back in there and create a new one.

Give me a couple of days.

1 Like

Hi…your git install instructions are predicated on the user having a github account. I ended up just downloading your source and then installing from there.
When I try to submit an asset, I get an Error 500: Internal Server Error. Mayhaps I have a bug in my install because I installed manually, but I’m not sure how to get around this.

Hello everyone, this is my first post. Fist of all would like to thank for great software , I love Screenly, came across Screenly not long ago and I have to say it is so easy to use, love it.
What to put my two cents about getting Screenly on PI4 to work. It is just a workaround and my experiment with PI4, I just though PI4 hardware is more powerful and it will play HD videos better.
So what I did was - get Screenly OSE to work on PI3 and then upgrade PI to buster since PI4 is not going to boot on other distribution. Removed SD card from PI3 and inserted into PI4, it has been working for me couple months, I am not utilizing dual display output just taking advantage of more powerful hardware.

Yeah I’ve seen the benchmarks, Pi4 is powerful…
I dont have a Pi 4 to test, but you mean you updated with this method?

Which branch of screenly-ose did you select? production/development/experimental

I followed instructions:

  1. In the files /etc/apt/sources.list and /etc/apt/sources.list.d/raspi.list , change every use of the word “stretch” to “buster”.
  2. In a terminal,

sudo apt update

and then

sudo apt dist-upgrade

  1. Wait for the upgrade to complete, answering ‘yes’ to any prompt. There may also be a point at which the install pauses while a page of information is shown on the screen – hold the ‘space’ key to scroll through all of this and then hit ‘q’ to continue.
  2. The update will take anywhere from half an hour to several hours, depending on your network speed. When it completes, reboot your Raspberry Pi.
  3. When the Pi has rebooted, launch ‘Appearance Settings’ from the main menu, go to the ‘Defaults’ tab, and press whichever ‘Set Defaults’ button is appropriate for your screen size in order to load the new UI theme.
  4. Buster will have installed several new applications which we do not support. To remove these, open a terminal window and

sudo apt purge timidity lxmusic gnome-disk-utility deluge-gtk evince wicd wicd-gtk clipit usermode gucharmap gnome-system-tools pavucontrol

Works fine on 16gb Sandinsk Ultra SD card.

Hi, im trying Rpi 4 with Screenly and i’m getting this error which i’m not getting on RPI 3b+ with same versions.
I cannot add any video, no matter which extension, codec, etc. I can add images.
Any idea?

06.05.20 11:48:43 (-0300) Traceback (most recent call last):
06.05.20 11:48:43 (-0300) File “”, line 690, in api_view
06.05.20 11:48:43 (-0300) return view(*args, **kwargs)
06.05.20 11:48:43 (-0300) File “/usr/local/lib/python2.7/dist-packages/flask_restful_swagger_2/”, line 219, in inner
06.05.20 11:48:43 (-0300) return f(self, *args, **kwargs)
06.05.20 11:48:43 (-0300) File “”, line 1019, in post
06.05.20 11:48:43 (-0300) asset = prepare_asset_v1_2(request_environ, unique_name=True)
06.05.20 11:48:43 (-0300) File “”, line 553, in prepare_asset_v1_2
06.05.20 11:48:43 (-0300) asset[‘duration’] = int(get_video_duration(uri).total_seconds())
06.05.20 11:48:43 (-0300) File “/data/screenly/lib/”, line 184, in get_video_duration
06.05.20 11:48:43 (-0300) run_player = ffprobe(’-i’, file, _err_to_out=True)
06.05.20 11:48:43 (-0300) NameError: global name ‘ffprobe’ is not defined

1 Like

do you have ffmpeg package installed?
dpkg -l | grep -i ffmpeg

i’m sure there is some package situation going on… does the rpi4 and rpi3 have the same version of raspbian?