Screenly Forum

No internet - no screenly

I just noticed that if the PI boots while it doesn’t have internet connectivity, screenly does not work, it sits at a screenly splash page displaying no asset, soon as internet is connected to the pi, it resumes displaying the asset. Is this something configurable? Or how can I get around this so it displays the asset regardless of internet connectivity?

is the asset a URL? or a locally uploaded image/video/etc? if you dont have internet connectivity how can the asset work?

the asset is a JPEG, locally uploaded.
Is there a max size you recommend for the locally uploaded JPEG images? Is a PNG preferable or does it matter? At first I though it was taking too long to display given a 10 second re-cycle, so I changed it to a minute but no diff.

would it be possible for you to upload the jpeg here so i can test?
I have never had an issue uploading images as assets…
attached below is an example of both types jpeg and png i uploaded to test…
the max size really depends on your resolution you set for the raspberry pi, these images are 5MB and less, i really dont think size matters to be honest, one of these pictures i uploaded to test was manually enlarged to 4096x3000 pixels and its 5.3MB, remember the pi will play HD videos hundreds of megabytes in size, a tiny 10MB image is nothing for the pi…

i really think there is something else going on that you cant see image, what version of screenly are you running? can you send screenshot of system info?