Screenly Forum

Blank Screen When Screenly Boots Via BalenaCloud

Hi all,

I’ve started messing about with a project utilising Screenly via BalenaCloud onto a Rasp Pi 3B+, but I’ve hit an issue where I’ve deployed the code to BalenaCloud, had it install on Rasp Pi but when Screenly loads and is supposed to show the initial page displaying the IP address, it’s just blank.
I have installed Screenly OSE via Balena Cloud but once the Screenly app launches at boot the screen goes blank. I can prove the HDMI output is working because when restarting the device I am able to see the boot screen and Balena logo for a few seconds before it goes blank (I’m assuming this is where Screenly kicks in). The monitor is receiving a signal from the device but nothing is being displayed because it never goes “off” or says No Signal.

I have had a look around the forum and tried the following device configs to no success:
RESIN_HOST_CONFIG_hdmi_group 1
RESIN_HOST_CONFIG_sdtv_aspect 3

Device - Rasp Pi 3B+
Code Deployed - 2019-09-25-Screenly-OSE

I should point out I am pretty new to all this so I’m trying to get my head around the Linux world so please forgive any glaring ignorance or missed important information.

I did take a look at the logs via BalenaCloud for what it was worth and while I couldn’t work out everything that was going on, I can see the Screenly Server service gets restarted every minute or two, not sure if this is normal behavior though.

Hi Jason!

Looking at your post history, it seems that you resolved this issue. Am I right?

If yes, you should post how you solved it. It would likely help someone in the same situation as you where.


Hey Matvei,

Apologies, I had forgot I posted this issue here. It seems I had a bad install possibly from a dodgy SD Card reader, after using a new reader and going through the process again it seems to be working fine now.