Anthias installation doesn't start on Raspbian

Hello everyone!

I’m trying to install Anthias on the latest version of Raspbian Lite 32bits (2023-05-03) but when I want to execute the command

# bash <(curl -sL

nothing just happens.

Tried running just the curl portion and nothing happened either

# curl -sL

I attach a screenshot of my console

The strange thing about all this is that until a few weeks ago, I had been able to install it by this method without any problem.

I tried to use older versions of Raspbian and even 64-bit versions, but I couldn’t solve the problem.

I also tried to directly use the Anthias image, but the problem is that I don’t know how to enable SSH once the image is loaded on my SD

If anyone could help me I would greatly appreciate it!

Original message in Spanish

Hola a Todos!

Estoy tratando de instalar Anthias en la ultima versión de Raspbian Lite 32bits (2023-05-03) pero al querer ejecutar el comando

# bash <(curl -sL

simplemente no sucede nada.

Intente correr solo la porción del curl y tampoco sucedía nada

# curl -sL

Adjunto una captura de mi consola

Lo extraño de todo esto, es que hasta hace unas semanas, había podido instalarlo por este método sin problema alguno.

Intente utilizar versiones mas antiguas de Raspbian e incluso versiones de 64 bits, pero no pude solucionar el problema.

Ademas intente utilizar directamente la imagen de Anthias, pero el problema es que no se como habilitar SSH una vez cargada la imagen en mi SD

Si alguien pudiera ayudarme lo agradecería de sobremanera!

@Statistic3514, I’ll try to replicate this on my Pi 3. In the meantime, what version of Raspberry Pi is the Raspbian running?

@Statistic3514, I can see that you are logged in to the terminal as the root user. Did you flash your microSD card with Raspbian via the Raspberry Pi Imager? If yes, would you be able to provide the settings that you’ve used when imaging the microSD card?

I flashed mine with a 32-bit Raspbian Lite (2023-05-03) and logged in as a non-root user. I haven’t experienced the same error.

I’d love to hear back from you about the details.


Use the same version that you mention (2023-05-03), below I attach the configuration that I use in Raspberry Pi Imager.

I enable the root user to work by first setting a password for it:

$ sudo su
# passwd

And then modify the /etc/ssh/sshd_config file to enable root login

I’m going to try to install with the user pi to see what happens

My sincere suggestion/advise:
Don’t waste time trying to install Anthias on 32-bit Raspbian lite, use 64 bit and follow steps here:

Thanks @ealmonte32. @Statistic3514, Alternatively, if using the Raspberry Pi Imager doesn’t suit your use case(s) anymore, you can try using balenaEtcher. It’s important to take note that you won’t have a more granular UI control over the configs like what the Pi Imager provides. However, you can customize most of the settings after device boot.

I agree with @ealmonte32 that most of the config can be done via the raspi-config command.

1 Like

@Statistic3514, if we are to look closely at the installer code, the script is written to run on a terminal as a non-root user. Moving forward, I suggest that you’re logged in as a non-root user before running the installer script.

Update: I haven’t experienced the issue yet. The installation was successful. I was able to upload assets without further issues. But again, we recommend using a 64-bit RPi OS Lite on the Pi prior to installation.

Update: 64-bit RPi OS Lite is only supported by Raspberry Pi 3 and 4. For RPi 1 and 2, use 32-bit.

Just an update in case anybody comes across the same issue. I had the same behavior as OP, and realized it was because my network blocks common NTP (Internet time) servers, so the date and time weren’t being set. This causes the device not to accept website security certificates so the install fails immediately and silently.

By setting the time manually using sudo date, I was able to get past this issue. Looking at the OP’s console log, it looks like they had the same issue. Their date was showing as 2022 despite posting in 2023.