Installing Anthias on Raspberry Pi 3 A+ fails

Hi all, new user here.
I am trying to install Anthias on a Raspberry Pi 3 A+. I followed the procedure found here in several topics. I tried with Buster lite 64 and 32 bits, Bullseye lite 64 and 32 bit, tried on two different A+, used Balena etcher etc… The installation was done using bash <(curl -sL as indicated on Github.
Everything works ok with out any errors until it gets here:

pi@anthias:~ $ ./screenly/bin/
[+] Running 7/7
⠿ redis Pulled 2.2s
⠿ srly-ose-celery Pulled 2.3s
⠿ srly-ose-wifi-connect Pulled 2.2s
⠿ srly-ose-server Pulled 2.3s
⠿ srly-ose-websocket Pulled 2.2s
⠿ srly-ose-nginx Pulled 2.3s
⠿ srly-ose-viewer Pulled 2.3s
[+] Running 7/8
⠿ Network screenly_default Created 0.6s
⠿ Container screenly-redis-1 Started 17.4s
⠿ Container screenly-srly-ose-server-1 Started 17.4s
⠿ Container screenly-srly-ose-wifi-connect-1 Started 12.0s
⠿ Container screenly-srly-ose-websocket-1 Started 486.5s
⠿ Container screenly-srly-ose-viewer-1 Started 486.5s
⠿ Container screenly-srly-ose-celery-1 Started 486.5s
⠿ Container screenly-srly-ose-nginx-1 Starting <— It never gets past this point

The nginx container is never started. I waited for several hours and nothing changed. Ping was possible for a few minutes, SSH login also. But that stopped after a while. The green LED is on and the Pi gets rather warm. When I unplug it and plug it back in, it obviously tries the same thing again. So if I want to try something else I have to reimage the SD card…
Any suggestions how to get this working?

Can you provide any logs after running the ./screenly/bin/ script?

I can try to create a Putty log. Once it gets to the nginx container start mentioned above, it freezes there forever. Even when I restart, it just gets back to that point within seconds. Don’t know if it’s possible to stop the process in any way.

So I repeated the whole procedure again and this time I got a few steps further. I have a Putty log but I am not sure how or if I can attach it here…
All the containers were created and started. Then it did “sudo apt-get autoclean” After Reading the package list, it started “Build dependency tree…” It took about 4 hours to get to 11%. Then it dropped the network connection. Similar to before, the green LED is on, no ping or SSH possible. The installation got to this point in one go. No reboot in between. At some point the screen turned white with a small black blinking rectangle at the bottom. I will let it run over night and see if it finishes.

[+] Running 10/11
⠿ Network screenly_default Created 0.8s
⠿ Volume “screenly_resin-data” Created 0.0s
⠿ Volume “screenly_redis-data” Created 0.0s
⠿ Container screenly-srly-ose-server-1 Started 8.0s
⠿ Container screenly-srly-ose-wifi-connect-1 Started 6.1s
⠿ Container screenly-redis-1 Started 8.2s
⠿ Container screenly-srly-ose-viewer-1 Started 13.8s
⠿ Container screenly-srly-ose-websocket-1 Started 13.8s
⠿ Container screenly-srly-ose-celery-1 Started 13.8s
⠿ Container screenly-srly-ose-nginx-1 Started 54.5s
⠦ srly-ose-viewer Your kernel does not support memory limit capabilities or the cgroup is not mounted. Limitation discarded. 0.0s

  • sudo apt-get autoclean
    Reading package lists… 0%
    Reading package lists… 100%
    Reading package lists… Done

Building dependency tree… 0%
Building dependency tree… 0%
Building dependency tree… 0%
Building dependency tree… 1%
Building dependency tree… 2%
Building dependency tree… 3%
Building dependency tree… 4%
Building dependency tree… 5%
Building dependency tree… 6%
Building dependency tree… 7%
Building dependency tree… 8%
Building dependency tree… 9%
Building dependency tree… 10%
Building dependency tree… 11%

By any chance is this a brand new SD card or a used one? because we need to rule that out as the culprit.
Also, putty log is not the same as the log from journalctl because I wanted to see if there is some log messages in the background while your containers were being built that had some errors we dont see in the installation putty screen. But now that you reinstalled and it went further, it seems like it might be the SD card, because nothing changed during installation (nothing in the master branch has changed since you did the first install), and you did the same exact steps with the same exact hardware…

So after two more failed attempts with different SD cards, I decided to try it on a Raspberry Pi 3 B+. I used exactly the same procedure and this time it went right through without any problems.
Just out of curiosity, I inserted the same card into the A+. It booted to the blank screen and I pressed Ctrl+Alt+F1. I got the login prompt, typed in “pi” ad that’s it… Nothing else. A bit later there was a message: Login timed out after 60 seconds. I also tried to connect with SSH. There I got just an empty screen but it never timed out.
Did anybody here ever got this running on an A+? I see some topics about the Pi Zero but I could not find anything about the A+.

Hmm… that is weird because although the Pi 3A+ is a lower end version of the 3B+, the underlying OS should have worked the same, so yes I can imagine the installation taking a very long time vs the B+ but I haven’t seen a lot of testing or troubleshooting on 3A+ to even know where to begin diagnosing it…

Also, the config.txt file going from one raspberry pi to another might not be good since it can contain reference to something that was generated from the other board and that the 3A doesn’t support… maybe you need to update the firmware or something on the 3A, why dont you use one of your SD cards to install the raspberry pi OS lite on it, run it, log in and run sudo rpi-update see if it updates, then after that try the bash installation again.