Anyone have issues with latest builds and SSL?

I am running on a Raspberry Pi 3B+. We’ve been using a Balena build based on commit 97a0abd from April 12, 2021. We figured with all of the updates, and change of branding related to Screenly → Anthias that we’d get back on track with updates.

Unfortunately we were unable to get a Balena build to work due to errors related to bind (I’ve commented in a Github issue about this).

That said, to stay current, we were going to forgo Balena temporarily and just run locally. However, we centralize access to our individual screens (2 total) via a web interface and use iframes to switch between them. Our interface is running SSL, so we need whatever page we load to also use SSL. Despite the successfully running without error (multiple times over), the Screenly/Anthias connection reports “Connection refused”. We are not running any additional software on the device (no firewall outside of anything provided in the image).

At this point I think we might go back to our older build and try again in a few months, but…

Curious to know if anyone else has had similar issues, and/or is able to reproduce the issue so that I’m not just going insane. Thanks! Willing to help debug (with direction) if it’s at all helpful.


The dockerized version has yet to include a simple way to enable ssl since the docker-compose and Dockerfiles would need to be updated to include port changes and automated certificate creation, etc., then containers rebuilt/recreated with the → 443 rather than 80 for nginx.

If you know some ansible/bash scripting and can help contribute to development then this would be a good task/item to work on.

The script actually calls some ansible scripting. There’s a warning about bash using the discovered Python interpreter (and there are 3 Python folders in /usr/bin), so maybe v3.9 is the wrong one for the ansible script?

I’m extremely weak on Docker, *nix, and never touched ansible. I’ll try to look into it, but I definitely can’t make any promises on that one.

Thanks for the reply!