Latest update broke install on Pi 3B

I ran the install sh to update both of my Anthias instances on 2 Pi3B cards and I cannot access the web interface and the TV output is black.

I ran docker ps and confirmed the containers are running:

I rebuilt the containers as well just to try. :slight_smile:


Always try to get logs from containers viewer, server, and so on… one of them will say where the error lies.

Pardon me, I’m not sure how to get logs from the Docker containers :joy:

type in docker logs screenly-anthias- … press tab and it will autocomplete for you the name of the containers or part of it.

Ref: docker logs

I’m not sure if the update didn’t push out the new docker names or what, but mine are still all prefixed with “screenly-srly-ose”, just FYI.

Here’s an error I’m repeatedly getting with the nginx container:

Checking the other containers

All other containers look fine

Didn’t you do some custom stuff to your nginx file…?
I am not getting this and I did a fresh install so it’s not a normal troubleshooting help when the user customizes / edits the container files etc and gets errors.

Also, you most likely did not rebuild your containers, you probably just ran the normal upgrade containers which does not contain the build parameter which will force a rebuild of all containers with all updated info…

All I recall doing was adjusting the subnet mask per your recommendation:

I would try to examine the config but I keep getting booted out when I bash into the container:

(Not your problem, just sharing haha)

why are you adding something else after the nginx/ sites… area, this is just a tab to auto complete…

I did this just now works perfectly fine…


I was trying to type it manually because initially auto-completing it was booting me out, like I showed in the GIF, so I thought maybe my tabbing was causing it.

You can disregard this post if following your advice from a previous post now nullifies my eligibility for support. I’m considering paid Screenly; OSE is too unstable lately.

Anthias is all volunteer and community support, so what I meant was that it is hard to troubleshoot / help users that customize their units because I or if someone else helps, can’t keep track of what changes you’ve made, even if we suggest those changes, and if we suggest changes they are usually to fix something specifically for you, not for the Anthias system itself, otherwise that would be in the GitHub Issues and repo as a PR fix.

Basically, you have an issue after doing the upgrade from within a system that was already running, I would suggest doing a complete reinstall but instead of doing a whole flashing the SD card steps and doing all those previous steps, you simply completely delete your docker images/containers.
To do so, you would need to run the following commands:

stop and remove all containers:
sudo docker stop $(sudo docker ps -a -q) && sudo docker rm $(sudo docker ps -a -q)

remove all docker images and docker data:
sudo docker rmi $(sudo docker images -a -q) && sudo docker system prune -a

Then, you can run the bash install script and I would simply suggest pressing yes to running the upgrade so that packages are updated.
This creates all containers again using the latest master repo but beware that during this Python3 migration there are some errors here and there, thus if you can try to fix the nginx error for now, that would be better since we dont know how many other things are broken during Py3 migration besides the ones reported by users and ones we find ourselves.