Screenly Forum

How to change default monitor resolution

Hello,

I new to Screenly and Pi. However, I’m fairly knowledgeable about computers and have dabbled with Linux.

I have Screenly-OSE running on a Pi Zero W. It is connected via HDMI to an HD TV screen. I have two 1920x1024 resolution jpeg images uploaded to assets. However, the monitor defaults to 640x480. This makes the images very blurry and there is a huge black areas around the main area. The default assets also look very bad.

I have read several similar posts and I have tried changing settings in the config.txt to no avail. Is there someplace else that I can modify the default monitor settings?

From the System Info page:
Monitor Info: state 0xa [HDMI DMT (4) RGB full 4:3], 640x480 @ 60.00Hz, progressive
Screenly Version: production@d12df55

Thank you, in advance, for any assistance you can provide.

if you’re able to SSH into the Pi or use physical keyboard on it, try to manually change the resolution using sudo raspi-config and find the option 7, then A5, and choose the CEA mode you wish to use… then reboot.

Hi,

Thank you. I appreciate your reply.

I’ll give that a try.

Regards,

Dana Scott
scotilv@icloud.com

Sorry I haven’t responded. I had to be away for a few days. I’ll try it soon and let you know.

I finally got to work on this today.

Since I installed Screenly from the image, there is no raspbian OS, so no way to get to the rapsi-config. So I reformatted the SD, installed NOOBS and selected Screenly from the selection menu. It installed, but when it rebooted, no display. I popped it back into my Mac and uncommented the HDMI safe mode in config.txt. Then it wouldn’t boot at all in the Pi Zero W.

I noticed on the reboot to hold Shift to go to recovery. So I did and got back to the NOOBS screen where I selected to install the OS. After installation, I could run sudo raspi-config, but unfortunately there is no option 7. However, there is an option 2 Display Options, then D1 Resolution, that sets display resolution. I selected the last option for DMT Mode 82 1920x1080 60Hz 16:9. I also selected D2 Underscan to remove the black border around the screen.

Ok, now to restart and run Screenly-OSE.

Fail. The screen size looked ok as the Screenly splashpage looked good. It still didn’t cover the entire screen. But when it booted, it took reset the wifi to it’s own and the text on the screen was so distorted I couldn’t read it. And I cannot use the Shift to go to recovery. So I’m back to square one for the 20th time. :face_with_symbols_over_mouth:

I’m about to give up on running Screenly on a Pi Zero W at anything over 640x480, even though it is supposed to.

Thanks,

Hello again,

I was able to reset the resolution in the os-config.json so I could see the wifi password. At the same time, I finally able to figure out how enable ssh on the Pi 0. When rebooted, I found I was able to access raspi-config via ssh. I’m learning…

Unfortunately, no matter how I change the resolution or overscan I cannot get the black edges to go away, nor can I get the resolution to clear up.

Now I’m beginning to think it’s the TV I have it connected to. I’m going to try it with my computer monitor and will update here.

Thanks for your patience, and hopefully someone will view this and offer more suggestions.

Regards,

Ok, It’s not the TV as the monitor I’m using does exactly the same.

I’ve found that no matter how I change the config.txt or raspi-config, the screen resolution in Screenly shows the same as in my original post, “…640x480…” and the display is distorted, almost unreadable. I have verified that the images are 1920x1080, which Screenly says are supported.

Like another posted said in Oct '20, “Not a good first experience”

@dscoti
First I wanted to clear up something just for your own learning as you say you are, the Screenly image you download and burn it into the SD card is running Raspbian OS or else there wouldn’t be any system at all, if you did not know how to reach raspi-config, you could have asked and I would have explained that you either needed to press Ctrl+Alt+F1 to get into the console physically or SSH into the Pi. So to confirm, Raspbian OS is the operating system that Screenly runs on, if your system somehow did not have raspi-config, you would have simply installed it by downloading it from here: GitHub - RPi-Distro/raspi-config: Configuration tool for the Raspberry Pi

Ok, so about the os-config.json file, where is this file from because Screenly or Raspbian do not use this? are you using balena by any chance?

Also, the resolution situation is def not screenly related since I have a Pi zero W here and tested and works fine with monitor and TV.

When you configure the resolution, please set it up properly according to what hardware you are using, when you said you were using a TV I specifically mentioned CEA for a reason.

Reference:
CEA modes are intended for TV, they include plenty of interlaced and progressive modes, usually with 25/50/100Hz (PAL) or 30/60/120Hz (NTSC) frame rates and TV resolutions of 288/480/576/720/1080 scan lines. DMT modes are intended for computer monitors, therefore there are none of the interlaced modes, the resolutions are 640/720/800/1024/1280 and the frame rates are compatible with the computer monitors, something like 60/70/75/80/85/120Hz.

For the overscan situation, you can simply manually try different negative numbers on the /boot/config.txt file, which I have done in the past to get the entire image onto a TV, these are the numbers I had to use to get no black areas showing:

overscan_left=-14
overscan_right=-14
overscan_top=-32
overscan_bottom=-32

But, your primary situation is that of a resolution, what cables are you using to connect to the TV?

I would suggest you to use balenaEtcher to burn the latst Raspbian OS lite directly from raspberry downloads onto your SD card for the Pi zero W:
http://downloads.raspberrypi.org/raspios_lite_armhf/images/raspios_lite_armhf-2021-01-12/2021-01-11-raspios-buster-armhf-lite.zip

Then, run the bash install script to install screenly rather than using the images.
One very easy way to set up wireless and ssh on the device, is to do the following:

  1. Once the Raspbian OS system has been burned on the SD card, remove it and re-insert it into your computer so that the volume can be mounted as /boot/ and you can edit files inside it.

  2. create a file called wpa_supplicant.conf and in there fill it out with your wifi settings… I have written a little guide to doing this on one of my projects and I recommend quickly reading it here: Digital-Signage-Based-User-Targerd-Advertising/Software/API at main · viradhanus/Digital-Signage-Based-User-Targerd-Advertising · GitHub

  3. you should also create an empty file called ssh (it could be a text file or just using the touch command to create it) in this same SD card /boot/ volume to automatically enable SSH on the Pi.

So, in general, this resolution situation is really an issue on a case by case basis since the resolution is handled by the Raspbian OS, not specifically by Screenly…

Hello again,

Thank you for all your help and for your very clear and knowledgeable reply. I appreciate the opportunity you have provided for me to learn.

Yes, as I said, I am new to Pi, and I eventually found almost everything you listed. As I said in one of my replies, I found how to add SSH and how to get to raspi-config. I didn’t think about asking how to get there as you suggested just now, but since I found out myself, it’s a lesson I’ll never forget.

I was not using Balena, however, I did spend some time looking at it.

I did make sure I was using the correct mode for the type of display, especially after you mentioned it. I have no clue why I couldn’t get either display to show a clear, legible image. I also adjusted the overscan numbers to no avail.

I eventually did install Raspbian directly onto the card and then used bash to install screenly. Interestingly, before I installed Screenly, Raspbian looked great. It filled the screen and was clear.

I’m using HDMI cables with the mini adapter provided. I tried 3 or 4 different ones. I did find one was marginal and tossed it out. I was wondering if it is possible that I got a defective Pi 0? I know electronics can and do fail, sometimes

I’m giving Screenly a break for a while to let my own frustration settle down.

Again, I can’t tell you how much I appreciate your time, patience, help, and clear instructions.

Regards,

Dana Scott
scotilv@icloud.com

1 Like

Thank you for all your help and for your very clear and knowledgeable reply. I appreciate the opportunity you have provided for me to learn.

You’re welcome.


I eventually did install Raspbian directly onto the card and then used bash to install screenly. Interestingly, before I installed Screenly, Raspbian looked great. It filled the screen and was clear.

This proves your Pi zero W and the HDMI cable are working perfectly fine.

It is hard now to pinpoint why exactly installing Screenly changes the screen resolution as if the “display” driver is uninstalled like on windows computers, which isn’t obviously the case here, but just mentioning in order to get the idea of what I mean…

Quick question, just to confirm, did you Disable Overscan via the raspi-config? Because it should be Disabled, just wanted to make sure you did this.
Whenever you get back to troubleshooting this, just let me know, it seems it is simply a setting/config somewhere because your HDMI cable and Pi zero w work fine as you said when running Raspbian OS without Screenly.

Reference reading: Raspberry PI Zero - Screen resolution not OK - Raspberry Pi Forums

Hello,

I haven’t forgotten your generous offer of assistance. I just put it down for a while. I will reach out when I pick it up again.

Regards,

Dana Scott
scotilv@icloud.com

No problem Dana, sounds good.