Installing Anthias (pi3) from the Raspberry Pi Imager v1.7.4 just hangs at the logo

The title. That’s it. I see it in my network, but I can’t connect to it. It is just showing the Anthias logo. Has anyone got this to work for a longer period of time, including reboots?

Hi, @pepeu. Were you able to get the logs (e.g., using a serial cable), if not by SSH?

No, I don’t have a serial cable available I’m afraid.

No worries. If it will work on a fresh install, I can check if it works via an update (via ./bin/, or via the install script, which also runs

Pardon my noobness, but how am I supposed to update when I can’t connect to it?

Apologies. Haven’t thought of options other than the serial cable. Not an expert in networking and stuff, but have you tried doing SSH (with your laptop/PC connected to the Pi via the Ethernet cable)?

Yea, but all I get is Network error. Connection refused. This was from when installing from the imager. Do I have to anything in particular to get SSH working? I just changed the config file to fix the overscan and threw in an empty SSH file.

I did a fresh install of Anthias on RPiOS Lite on Pi 4 but haven’t experienced the issue.
I’ll try to replicate the issue via ./bin/ instead of the installer script.
I’ll also do a fresh install on Pi 3.

Hello again, @pepeu. I also did a fresh install on a Pi 3, but haven’t reproduced the issue.
I can still access the web UI (via browser) and the terminal (via SSH). Are the devices connected via Wi-Fi?

No, it was through ethernet. I’m redoing it now, since I get fed up with just seeing the logo. Just to be sure, how will I be able to SSH into it? Is throwing in an empty SSH file in there going to suffice? Or is that only when doing it from a “normal” Linux dist?

I just want them to go through ethernet, since the wifi at where they’ll end up (a community center) has flaky wifi at the moment and don’t want the extra hassle.

Fresh install, no web UI. Just stuck on logo.

Thanks… It’s weird that I’m still not able to reproduce the issue… What OS did you install – the 32-bit or the 64-bit one; are you using the Bullseye or the Buster one?

Neither in these two attempts. I was installing Anthias (pi3) from the Raspberry Pi Imager v1.7.4. What would you suggest I do it from? 32/64/Bullseye/Buster/blabla? And I need it to work after a reboot as well.

Oh, my bad. I though you’ve installed it via RPiOS Lite. At the moment, it’s recommended to install Anthias on a Raspberry Pi running Raspberry Pi OS Lite. You can check out the details here – Screenly/Anthias: The world’s most popular open source digital signage project. ( With this, you can have SSH access on your device.

On Raspberry Pi 3 with Anthias (pi3) installed via the imager, it will really take a while as the device is still downloading the necessary resources (e.g., Docker images). On my end, it took around 10 minutes, but it depends on the Internet connectivity. And also, Anthias Imager images are basically Balena images, and SSH is hardly possible in those instances.

Mkay, would you recommend that I install a 32 or 64 bit of Bullseye?

64-bit and make sure it is Raspbian OS Lite.