Screenly Forum

Screenly shows black screen only with google docs

Hi,

Since a couple of days my screenly is showing a black screen for google presentations the time it should present the doc. I can open and view the google doc on another PC so publishing should be OK.
When activating other assets (clock, weather,…) everything shows up on the screen and works fine. The moment it should start playing the google docs, it shows a black screen as if it can not show the doc.

The journalctl shows only normal behaviour:

nov 11 16:33:17 RASPI-SECRET python[725]: Starting new HTTPS connection (1): docs.google.com:443
nov 11 16:33:18 RASPI-SECRET python[725]: https://docs.google.com:443 "HEAD /presentation/d/e/2PACX-1vTZCq-5KvXwtLUQQ9ajQRbva-ruNrMTJ_6gk…

I upgraded screenly to the latest production version and also upgraded the system.
Somebody who knows what else to try?

Regards,
Jonas

Hi Jonas,

We started to experience the same thing here. We’ve been using Google Slides for several years without issue and now all of a sudden they’ve turned to black screen. I’ve also tried the same steps as you have, upgraded to the latest release etc. but no luck.

Thanks,
YJ

Funny, this forum seemed dead and I was about to wake it making a post about this exact matter. By the time it took to register the account 2 threads with the same error appeared.

I have been troubleshooting this all day with no luck.

Started off with unsupported browser message.
After update screen only goes black when presenting Google slides.
Other web pages and widgets work as expected.

Could this be the work of Google trying to offload their servers?

Yes, I have a strong feeling that it is something that Google has changed recently. It would be fantastic if someone actively involved in the Screenly OSE dev team is aware of this and there is a fix on the horizon!

Hi,
Same problem in our school. Tried to fix the issue too, with no more luck.
We will work with minimal service with PNG or JPG until a fix is found.

Kind regards,
Fred

Hi,

Same here. Hoping that the dev team are aware of the issue, currently using JPG/PNG as a work around.

Same here. A 4-minute Google Presentation has become 4 minutes of black screen. My workaround is to export my Google Presentation (Slides) as PowerPoint (pptx) I then open the file in PowerPoint and export as video. The video plays back as expected in my several Screenly OSE Raspberry Pi (s). Disadvantages: i) the edges of the slides have been cropped a bit, causing some odd alignments and some loss of meaningful text. ii) changing the content of a single slide becomes a 30+ minute process.

SUCCESS! - My Google Slides are behaving normally after a fresh install of the OSE download labeled ‘2020-07-17-Screenly OSE’. Running version = production@d12df55 (from the ‘settings’ screen)

Okay, I know nothing! One of my other Raspberry Pi’s, running Screenly OSE from ~2017/18/19(?) started working again, on its own. That is, it started showing my Google Slides / Presentation. It has been running for years. Recently, it was showing a black screen in place of the slides, but then it started showing them as normal. I can’t explain it.

Hi,
Indeed, I tested yesterday and it works again. I did have to remove the asset and added it again…
Regards,
Jonas