Use FTP server instead of local storage?

Is it possible to make it so that screenly reads content from an ftp server on another computer rather than from the SD card?

You mean when you add/upload Assets? like adding your FTP server address as the Asset location or uploading content (files) to the Pi? Is this not what you would want to do?? Can you pls elaborate…

Exactly. When i upload assets, i want it to upload to an FTP server instead of the SD card of the pi, and then i want screenly to read from that FTP server instead of the SD card. Cheers!

this is essentially you adding a URL asset, screenly is not an FTP client to be able to grab a file and pipe the login to the FTP server and put the file and then add the URL of that file back to the Assets…

if you want to pull files from an FTP server or another computer, simply use a program first like FileZilla to upload the files to such server, and then when you add the assets you can type that URL in there… but i am not sure this protocol will work as HTTP/S since it is FTP and meant to not use MIME types… dont want to get too technical but you are trying to achieve something basically unnecessary.

I see thanks for your answer. Well Iam running a store with screenly, i want other stores/suppliers to be able to remotely upload content to my screenly so that i don’t need to maintain it at all, so that some other “guy” can control everything.

I see… so you just need to follow this way of doing it:

if you for some reason dont want to do it that way… you can achieve this different ways… one is by making your Screenly accessible to the public internet using port forwarding and static IP assignment, but of course with network security in place which you would need to determine which is best depending on your own situation… (make sure you enable HTTPS on the Screenly by running the script located in ./screenly/bin/
For this reason I recommend balena setup even if more steps are necessary during initial setup…

I will try that, thank you very much for the help!

One more question, I’m trying to add my local FTP server to assets.

Any idea why it says that the URL is wrong? Since it works from my browser. Thanks!

Are you not using the production version of Screenly? The skip asset check as far as I know is not an option on the experimental branch/version… is that what you picked when you were installing Screenly?

Well… I installed Balena and picked the image from github… How do i know which version? I’m using Screenly Open Source.

type the following in terminal/console: cat ./
should output something like this:

pi@screenlypi:~ $ cat ./
Screenly version: production@8eabdfb
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.8 (stretch)
Release:        9.8
Codename:       stretch