Moving from WIFI to wired network

added, rebooted and no difference.
Should I be using /etc/network/interfaces file?

you could, but before we do that, can I see your dhcpcd.conf file?


add this under ipv4only:


And comment this out just in case:

#slaac private

I am not sure if it is case sensitive…
If none of this works I’ll have to test on my Pi which should be the same version/hardware as yours and all, but I’ll have to configure that file, which I dont have configured, I only use wpa_supplicant.conf which is for wifi, you could then just switch to /etc/network/interfaces and configure static IP there like this:

auto eth0
iface eth0 inet static

If you do switch remember to comment out all the interface information you added to it…

if I configure the networks.interfaces files, do I do anything to the dchpcd.conf file afterwards?

sorry - you already answered that part.
nothing of that worked. I even tried the network/interfaces file.

I am willing to reformat my SDCARD and start over if that helps at all.

Yes, you should comment out all the lines you added.
Matter fact, you can even remove that package instead of formatting the whole SD card:or just deleting the file, you choose which one you prefer:

To delete package: sudo apt purge dhcpcd5 -y

To delete the dhcpcd conf file: sudo rm -rf /etc/dhcpcd.conf

Make sure your network interfaces file is set up properly though, with the static IP as mentioned above.
The Pi should now boot up and network configuration should work off the network interfaces file…

All Raspbian images should come default with these:

ii  dhcpcd5                              1:6.11.5-1+rpt7                   armhf        DHCPv4, IPv6RA and DHCPv6 client with IPv4LL support
ii  isc-dhcp-client                      4.3.5-3+deb9u1                    armhf        DHCP client for automatically obtaining an IP address

P.S. I am going to go and try this out with dhcpcd5 and see why inet6=no and dhcp6=no did not work… I hate when these commands or config parameters change from one version of something to the next without an easy manpage description to say so…

wow - that didn’t work either. It’s as if the PI isn’t looking at any of those files.

Huh… are you telling me that your Pi is booting and seeing a IPv6 address on the screen?

And that you deleted the dhcpcd.conf file, and uninstalled dhcpcd5 package? and put the info we said on /etc/network/interfaces file?
That can’t be…

For us to know what is giving you this IP we should run cmd: sudo systemctl status | grep dhcp
And lets see what you have under the dir where leases are usually kept: cat /var/lib/dhcp

I can’t type a pipe. Shift \ = ~

Dan Hoffmann

Director of Information Technology

Illinois Community Credit Union

895-7752 | Web:

You are running into the default UK keyboard localisation issue.

Did you run the localisation options and made sure you set your Pi to en_US utf8? and keyboard to be PC104 and US?

To set localisation: sudo raspi-config , option 4, then change locale, scroll all the way to en_US and press space bar, that should select en_US.UTF-8 , then press tab to get to Ok, then press enter.
On next screen set system environment to en_US.UTF-8

Then, to set keyboard sometimes the raspi-config way doesnt work, but you can simply set it via keyboard config file:
sudo nano /etc/default/keyboard

# Consult the keyboard(5) manual page.

ctrl+x, y, enter, sudo reboot…

Btw, are you using network-manager? when you fix keyboard, let me know if this output shows Network Manager

dpkg -l | grep network

FYI: to investigate what was giving me my interface an IP, I typed
sudo systemctl status | grep dhcp
This then showed me that dhcpcd5 was controlling my interface because the service was dhcpcd and when you remove that package, then isc-dhcp-client takes over, and the network/interfaces file having the following lines on file make dhclient be the one controlling the interface lease now…

auto eth0
iface eth0 inet dhcp (i am using dhcp, but this is just to test and see what service is controlling the interface)

Ok. Here’s the latest.
I changed the keyboard layout to us. Rebooted. Shows a different ipv4 (the WiFi ip)

Network/int stil shows proper

The system to shows

Networking.service as loaded/failed/failed

Dan Hoffmann

Director of Information Technology

Illinois Community Credit Union

895-7752 | Web:

This Email is covered by the Electronic Communication Privacy Act, 18 U.S.C 2510-2521 and may be legally privileged. The information contained in this Email is intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, or the employee or agent responsible to deliver it to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error please immediately notify us by telephone and destroy the original message .

I’ll revisit in the am. I missed your last posts and have to cut my day short.

Ok, I am sure we will get to the bottom of it, I did not realize how late it was.

New day!

After several reboots I can confirm that dhcp is no longer enabled.

The pi only grabs a WiFi IP.
I can access the screenly console this way as well.

If I disable my work WiFi, I get unable to resolve local IP address.

I found this and followed the steps:

Still not connecting to my local wired network.

Ok, we can figure this out… we just have to take it step by step…

First thing is, did you flash/burn the SD card using the Screenly image or the Raspbian one?

I need to see the output of the following or else we are going to be playing the guessing game again.

sudo systemctl status | grep dhcp

Even if you have static set, I just want to see what service is being used.

Next, we need to know if you are using network-manager to manage the network, did you select Y for when screenly asked you if you wanted it to manage your network? If so, you probably have network-manager installed, which is another service/package that manages networking.

To verify this, I need to see the output of:

sudo dpkg -l | grep network

Now, if I remember correctly, you are simply trying to get static IP on eth0 (wired) working but not to display ipv6? if so, this should be as simple as purging any configuration you have with other services that are using your network and just setting up static IP in the /etc/network/interfaces file.

P.S. If you are using Putty to SSH into the Pi, you should change the Putty configuration: Window > Translation > from ISO-latin or whatever, to UTF8 so that your console displays properly and not weird symbols…

SD CARD = Screenly download
I believe DHCP & IPv6 are not longer issues.

Currently it will only boot into the WIFI network. I want it to boot to the wired network (eth0)

login as: pi
pi@’s password:
Linux RSBP-SYC 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Wed Apr 3 11:10:00 2019 from
pi@RSBP-SYC:~ sudo systemctl status | grep dhcp │ ├─5025 grep --color=auto dhcp │ └─404 /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helper -pf /var/run/ -lf /var/lib/NetworkManager/ -cf /var/lib/NetworkManager/dhclient-wlan0.conf wlan0 pi@RSBP-SYC:~ sudo dpkg -l | grep network
ii dirmngr 2.1.18-8~deb9u3 armhf GNU privacy guard - network certificate management service
ii glib-networking:armhf 2.50.0-1 armhf network-related giomodules for GLib
ii glib-networking-common 2.50.0-1 all network-related giomodules for GLib - data files
ii glib-networking-services 2.50.0-1 armhf network-related giomodules for GLib - D-Bus services
ii ifupdown 0.8.19 armhf high level tools to configure network interfaces
ii iproute2 4.9.0-1+deb9u1 armhf networking and traffic control tools
ii iputils-ping 3:20161105-1 armhf Tools to test the reachability of network hosts
ii net-tools 1.60+git20161116.90da8a0-1 armhf NET-3 networking toolkit
ii netbase 5.4 all Basic TCP/IP networking system
ii network-manager 1.6.2-3+deb9u2 armhf network management framework (daemon and userspace tools)
ii python-netifaces 0.10.4-0.1+b1 armhf portable network interface information - Python 2.x
ii traceroute 1:2.1.0-2 armhf Traces the route taken by packets over an IPv4/IPv6 network
pi@RSBP-SYC:~ $

And there it is, NetworkManager is controlling your connection.

So, if you dont want to start removing packages (networkmanager) and losing wifi (wlan0) configuration, you can simply tell Network Manager NOT to handle your interfaces.

We can do this by following some instructions found here:

Which boils down to putting both eth0 and wlan0 in your /etc/network/interfaces file, and either removing/purging NetworkManager from your Pi or telling its config to not manage the devices.

The file /etc/network/interfaces needs to contain the interfaces you dont want NetworkManager managing:

(This below should be in your /etc/network/interfaces file)
#wired interface
auto eth0
iface eth0 inet static
    info here
    info here
    info here

#wireless interface
auto wlan0
iface wlan0 inet static
    info here
    info here
    info here

And also the file /etc/NetworkManager/NetworkManager.conf needs to contain the following info:



Restart NetworkManager or reboot.

sudo /etc/init.d/network-manager restart or sudo reboot