Where is the rPi 4 image?

I’m reading the intro page on github and it links to

what the heck is WebView and QTWebEngine? I’m just looking for the rPi image for screenly OSE. I noticed there was 2020-07-17-Screenly-OSE.zip under sprint release 10.1 but it looks super old. (July 2020). Is that the latest one? if not, where does one find the latest one?

I had a look inside the qt5-5.15.2-buster-pi4.tar.gz archive and it doesn’t look like a linux OS image - just a bunch of folders.

I’m confused.

+1… help please


+2… I can’t get OSE to work on R Pi 4 B.

I have the same question. I wasn’t able to install Sceenly Ose on rPi 4. I got some rPi 3 running but got some problems with some web page so I tried on rPi 4 but doesn’t work at all. Maybe QT, QTWebEngine and WebView are updates but didn’t find how to install it. If somebody could answer these questions.

I am in the same boat. I get this error when trying to flash on belenaEtcher:

Missing Partition Table

It looks like this is not a bootable image. The image does not appear to contain a partition table, and might not be recognized or bootable by your device.

Does anyone have any ideas here?

Thanks in advance

There are no images available at this time for the latest version. I got it running by installing raspbian lite and then installing manually using:

$ bash <(curl -sL https://install-ose.srly.io)

Additionally, you need set your username in raspbian as ‘pi’ or it will not boot.

All that being said, after I got it running I discovered that I can not display video from my Pi4 which is an issue I have already posted about and still waiting for a solution.

Hope that helps.

For the pi username, one of the easiest things to implement is a userconf.txt file that includes the pi user already created with default raspberry as password like it used to be, and gets copied to the /boot/ partition if the /home/pi directory isnt detected.

With regards to your video playback issue, have you tried a recent reinstall? including running the ./screenly/bin/upgrade_containers.sh file? because I believe this video playback issue was fixed, I just tested on my pi4 and I can play a test mp4 video just fine.

Hello! I have tried all day to install screenly OSE(anthias) on my Pi 4, model B, ver1.5. I can access it through web, bat is not displaying anything on monitor, no default assets, no images, no video. Only black image or splash image, depends on how I flashed the card. How did you manage to make it working? I tried solutions posted here…


There are three methods for installing Anthias, if one way doesnt work right now, try another, here, I just said the same thing to another user: I simply can’t get Anthias to work! - Anthias / Balena - Anthias Forum (screenly.io)

Thank you, I tried several options listed on this forum. Please, tell me, the username and password must be pi with raspberry? Mandatory?

This is required as per Raspbian OS yes.
It is very simple to set up, you either place a text file in the /boot/ directory of the SD card named userconfig.txt which needs to contain the username you want to use and hashed password, or you create it upon initial booting of the Pi, the former is a headless way of doing it, instructions are in many online places. An update to Raspberry Pi OS Bullseye - Raspberry Pi