After booting the Pi, if the asset set is a single image, it doesn't display, the screen remains dark with only the small purple screenly logo in the center

Hi, as explained in the title of the post, I have configured about 40 Raspberries Pi b3+ with the latest version of Anthias but I noticed a small anomaly on all 40 devices. If I activate a single image in the assets, this is displayed correctly until I restart or turn the raspberry off and on again; in fact, after its restart, the single image is no longer displayed and the screen remains dark with only the small purple screenly logo in the center as if there were no assets set. It is important to specify that I have done many tests and I have found that this problem does not occur if I set an mp4 video as a single asset, nor if I put a website url as a single asset. Also very important is the fact that if I activate a second image in the assets (for example a white screen) then everything works properly, i.e. if I restart or turn on the Pi again, after booting, the images (which are now two) are displayed correctly . The problem therefore occurs under these conditions: 1) on power up and 2) with only one image loaded in the active assets. How can I solve this problem? Is there any trick I can use? Has this happened to anyone else ? Thank you all for your availability.

On power up with 2 images in active assets: works!

On power up with 1 website in active assets : works!

On power up with only 1 image in active assets: doesn’t work!

On power up with 1 video in active assets: works!

That’s a very strange bug. How did you install Anthias? Using the official disk image or by yourself on Raspberry Pi OS?

Hi, I installed anthias like this: I downloaded Raspberry Pi Imager then I downloaded Raspberry Pi OS Lite 64-bit ver. 2023-05-03 and installed it on the sd memory card of the raspberry pi 3 b+. Then I started the raspberry and configured some parameters with RASPI-CONFIG.

I have :
Disabled Underscan to eliminate black bars on monitor edges.
Renamed the default hostname.
Extend partition to whole memory card with Expand Filesystem.
Rotated the monitor with the command display_rotate=3 in the CONFIG.TXT file. (my monitors are all vertical)

Still in the same file I forced the graphic resolution with the 2 commands: hdmi_group=1 and hdi__mode=16. (but the problem remains even if I don’t activate it).

Then I configured the network part in the dhcpcd.conf file by setting the fixed IP, gateway and dns of my network.
Finally I rebooted and then ran the bash command to download and install Anthias : bash <(curl -sL


Am I doing something wrong?

If you’re using the image from Raspberry Pi Imager, the installation is moot as it is using a completely different system.

If you need such low level control of the system, It is advised that you instead use the Raspberry OS image and install Anthias manually.

Hi, actually I don’t understand what you mean. Could you explain yourself better? Am I not already using a raspberry OS image? I downloaded this file : and then uploaded it with The Pi Imager. Then I installed anthias by hand with the bash command. Should I use the Pi imager and load the anthias image directly without loading bullseye first? If you explain it to me better I would be grateful, thanks.

And yes, I confirm that I need more control, at least for the customization of the networking part (ssh, ip and hostname) and the display part (display rotate and display border)

I just gave it another try by downloading the latest version of Raspberry Pi Imager v.1.7.5 and then I installed the 2023-05-03-raspios-bullseye-arm64-lite.img.xz OS. Then, without changing ANYTHING I manually installed Anthias from the command line: bash <(curl -sL When it finished I rebooted and created 1 asset with only one image. It works until I turn it off and on again. When restarting, the small purple Screenly’s logo remains in the center of the Screen until I go to modify the assets by adding another image or reactivate the one already present… why? Something is wrong with this version…

I wanted to ask a question, I don’t know if it’s feasible. If I directly load the image of “Anthias” from “raspberry pi image” taking it in the section: “other specific purpouse OS” → “Anthias” → “Anthias Pi3”. Would I then have the command-line option to customize the following parameters?:

  1. Rotate the screen vertically
  2. Assign a static IP to the raspberry
  3. Change the hostname of the raspberry on the network
  4. Enable SSH and change the user password

Because if it were possible I would try to upload only Anthias, maybe it’s lighter, more efficient and less problematic.

The version available there will not allow you to make tall of those changes (2-4). In order to do that, you need to manually install Anthias on top of Raspberry Pi OS Lite.

ok, thank’s.
I tried now with Raspberry Lite OS version 32 bit instead of 64 bit but the problem remains. When I turn it off and on again if there is only one image in the assets, it is not displayed until the asset is recreated. It’s really frustrating.

Hello - I was having a similar issue but I notice that waiting a while the screen begins to show the assets. Did you wait a while?
I am having another issue in that after a period of time (about 45 mins) the assets stop showing and the screenly logo is there in the centre of the screen. I have two identical assets showing for bout 16 mins each, as I found this helped stop the system crashing back to the screenly logo.

I’m wondering if this is a config issue actually :thinking:

Hi, no unfortunately even if I wait several minutes, the image does not appear.

I tried playing with all the configuration possibilities, both in the asset page and in the settings page but nothing appears if the image is single. I also tried to use a little trick by adding a white background at 10 seconds as a second image and setting the duration of the real image to be displayed at around ten days, so that when switched on the white background is displayed for a handful of seconds and then always remain the image that I want. This seems to work but a new problem arises, when you go to delete the asset by changing the main photo, this does not change on the screen, the old one always remains active until I restart everything again.

@ westerncms. Hi, were you able to do any other tests? I still haven’t solved this annoying problem, have you? Regards