Anthias not starting asset

Hi everybody,

I installed the current Anthias on my Pi3 with Raspberry Pi OS Bullseye Lite the manual way (not with the Raspberry Pi Imager).

It´s more or less working, but if I reboot the Pi, the assets are not starting. The display only shows the screenly logo in drak blue on dark gray background. I have to go to the web page and click on “Next asset”. Then everything is ok, till next reboot.

The asset of cause have a valid start- and end- date and is set as active.

Do you have any Idea?

Hi @gallon,

Can you please wait a few minutes and see if it’s showing the assets or not?

Hi salmanfarisvp,
I´ve waited now ten minutes. No changes.

I don´t know if it helps, but when I reboot, that happens:

  1. Anthias Logo (on purple background) appears
  2. White screen appears for less then a second
  3. The screenly logo appears (blue on black background)

@gallon Thanks for checking, I will try to reproduce and check with the team and update.

cc @nicomiguelino

1 Like

Hi @salmanfarisvp,
I’ve found a similar problem on my PI3b with raspi os lite (x32) installed by bash on git running with wi-fi.

When i reboot, that happens:
1- colorfull raspberry square
2- the screen became white for some second
3- anthias logo on purple background with IP
4- screenly logo on dark background.

the situation is that i can reach screenly both via ip and ssh on the same IP, and the asset is working on the “forever” setting but it’s not display.
The only solution that i’ve found is that every time i save new “forever” setting, the asset start to be display.

I cannot figure it out a solution, can you please help?
thx <3

Hi @explora.andrea , Is it possible to check with 64-bit OS and try? Also, can you confirm the Raspberry Pi is working fine with generic OS - Displays over HDMI is ok.

1 Like

Hi @salmanfarisvp and @gallon,
at the end of the story i’ve found a solution.

in the webApp i’ve set all the asset to:
expiration day: forever
duration: 60 seconds

after this simple changement everythink work well, both at the begginning when i start the rasPi then after every changment

1 Like

@explora.andrea, we are glad that it worked on your end. However, I haven’t tested that setting on my Pi yet. It seems like a code-level issue. Let me create a GitHub issue that covers this topic, if it doesn’t exist yet.

EDIT: I created a GitHub issue: Anthias is not starting asset (gets stuck at the logo screen) · Issue #1882 · Screenly/Anthias · GitHub

1 Like

@explora.andrea, I tried setting up an asset to run Forever but the asset’s not showing up after succeeding boots (after the next immediate device boot). (I haven’t changed the duration to 60 secs. It’s still as 10s.)

Does everyone still experience the issue? I did a fresh install on my Pi 3B+ (Bullseye), but I can’t seem to replicate it anymore.

EDIT: Please let me know if it happens again. If it does, I’ll reopen Anthias is not starting asset (gets stuck at the logo screen) · Issue #1882 · Screenly/Anthias · GitHub.