Anthias on 4K screen

Hello,

I’ve installed Anthias with Raspberry Pi Imager on a Raspberry Pi 4.
No problem to use it with a fullHD screen (except the "Internal server error when the RP isn’t connected to Ethernet), but when I plug it to a 4K screen I have a blank screen (I can see the content during 1/2s, and blank screen) when :

  • Pictures are bigger than fullHD
  • Webpage is shown
  • Videos (but the sound works)

So, I have to use only fullHD pictures, which are not enlarged to fit the screen, it’s unusable.

Is there a solution for this ?

Thanks !

Hi @jouvrard ,

The system will configure the screen settings when it’s booting the first time, and after you change the screen, the configuration might be the same and that’s why it’s not displaying things properly. so you might need to change the screen setting from the raspberry pi or need to install a fresh install and connect the new monitor.

Ok thank you, I’ll try with a fresh install. :slight_smile:

Unfortunately, same problem after a fresh install and connect to the monitor. :frowning:

An other idea ? :slight_smile:

Hi, When Raspberry Pi is connected to the monitor it will adapt to the resolution of the monitor, and it will stay on. So it might be that the settings stay on even after the monitor is changed. So can you test with a fresh install and set up the Pi with a 4k monitor and see?

Hello,
It’s exactly what I did :

  • Fresh install on the Raspberry Pi
  • Connect to the 4K monitor as first connection
  • … Blank screen. :wink:

When I look at the config.txt file, I found some screen resolutions, but no 4K.
Maybe Anthias doesn’t work with 4K screen ?

Hey, Can you confirm again, that the problem only persists on the 4K monitors?

also please confirm the Raspberry Pi OS Verison you are using?

I confirm the problem only persists on the 4K monitors.

I tried with the Anthias OS available in the RP Imager, and with the img file (0.18.6).
I tried with RP Lit x64 and an install with the command line (
$ bash <(curl -sL https://install-anthias.srly.io)), but the installation failed.

Thanks

Hi @jouvrard The Image available on the Raspberry Imager is too outdated. Could you please install the OS as per the guide here Setting Up Anthias on Raspberry Pi for Digital Signage 🖥️ - Hackster.io and check?

For now, please use the Bullseye Lite.

1 Like

I follow the guide you mentionned.
The installation seems to be ok, but after the reboot I only have a… black screen… :frowning:

EDIT> I connected the RP to ethernet and after the black screen I have a blank one and “anthias-ngix the page can’t be found”.
I try to go to the webpage with the RP IP but “connection denied”.

I can connect the the RP with SSH.

Which OS you are using? I see, I have an issue with the Bookworm OS version but works fine with Bullseye Lite. Is it possible to share a log?

I currently try a new installation with "Raspberry Pi OS (Legacy, 64bits) Lite.
I’ll share with you the result.
Thanks for your help and the time you take for me. :+1:
1

@jouvrard Thanks for checking, please let me know your findings.

The install is just finished and… I don’t know why, now it works…

I didn’t configure the wifi connection in the Pi Imager and plug the RP to Ethernet, maybe the Wifi connection wasn’t good and the installation process failed… Maybe…

But now… How can I configure the Wifi connection ? :smiley:
I try to connect with SSH and my password is refused. I’m sure of it and it’s not the first time.
To be sure I put “test” as password, it’s quite simple ! :slight_smile:

I tried “Ctrl-Alt-F1” when Anthias is booting, but the starting process doesn’t stop and I lost command line to arrive to the Anthias screen.

I have a Wifi access point configured as client so, it’s not very important if the RP has no wifi connection but it you be simplier if it was the case. :wink:

EDIT> I tried to connect with Putty and it work.
Now I just have to find the command line to configure Wifi. :wink:

Awesome, Glad to know that :raised_hands:.

Looks like the network manager has an issue, I recently opened a new issue, you can find the details here Anthias Installation Freeze on Pi3B while choosing "Anthias to manage the network" when the raspberry Pi only use WiFi. · Issue #1845 · Screenly/Anthias · GitHub .

You can follow this guide to set up wifi over SSH. Please check and let me know.

I tested my self and it’s working. Please note - if you have space in between the wifi name or password please put in " ".

1 Like

It works ! :+1:

Now, I just have to try it on a 4K monitor, but it’s already far better than with the “Balena version”:

  • The wifi works (no more need of a wifi access point)
  • The web interface is faster

I’ll try it on a 4K monitor this afternoon (I’m in France for information) and I’ll keep you informed.

It works on 4K monitors too with your solution.

Many thanks for your help and your patience with all my questions ! :+1::slightly_smiling_face:

1 Like

@jouvrard Awesome, glad to know it :partying_face:.

1 Like