Installing on RPi2B fails: hangs at splash screen

Hi there, new to this forum :wave:

I tried installing Anthias on my Raspberry Pi 2B+ though the image, but fail to get this working.

I get a purple splash screen per the attached and cannot reach the Pi via SSH or web.

I tried with 2 different SD cards to be sure; on the 2nd SD card I used the Rpi imager to get Antrias directly.

Any idea on how to troubleshoot?

the fact that this shows means that it installed, so for ssh i would just say add the ssh.txt blank file to your /boot/ directory of the SD card, that should automatically enable SSH, once you remote to it, run this command ./screenly/bin/ and it would take a while but it should create the containers since i believe that is your issue just like we’ve seen many other times when this happens.

@ealmonte32 Actually, if @diode used the Raspberry Pi Imager (or the disk image), it’s not using Raspberry Pi OS, but rather BalenaOS. Thus you can’t enable SSH like that.

@diode It can take a while for the system to initiate and there’s unfortunately no feedback on the screen for this. For a Pi 2 in particular (which is very old by now), I’d leave it least 15 minutes for it to invoke. If you’re using anything slower than a Class 10 SD card, even longer.

Ah… keep forgetting the new premade images are all using balenaOS.

Sorry for the late response.
During cleanup over the weekend, I found a RPi3B+ collecting dust so upgraded to that one. There, the image works fine and I can reach the web interface.
Thanks for the pointers!

@diode, thanks for the feedback. It’s great to hear that you were able to make it work on an RPi 3B+. Are you still having trouble making it work on an RPi 2B?

It’s not working on the RPi2. I spent a few hours to get it to work but I’m not bothering any longer since I have it working on a RPi3B+ now.

1 Like