What is the Hello Anthias test?

The only spare RPi for my Anthias eval is:

OS: Debian GNU/Linux 12 (bookworm) aarch64
Host: Raspberry Pi 4 Model B Rev 1.5

I used RPi Imager for the Anthias (pi4) image. I got “Screen Saver?” utility working on the display screen but didn’t understand on how to customize the settings. So I went for the full Bookworm image and used the shell script for a fresh install of Anthias. After rebooting, I have SSH access but the display screen no longer has any Anthias screen.

How do I explore Anthias functionality, features, etc? Thanks.


Hi @baqwas ,

Can you try to run “upgrade_containers.sh” from /home/$USER/screenly/bin/upgrade_containers.sh to complete the installation and see if it’s showing Anthia’s logo on the screen?

Very strange. There is nothing under /home/admin/screenly where admin is the user account. The only folder under /home is admin. Did a search for files/folders having the string screenly and it turned up only /home/admin/screenly.

I really don’t know what is going on because the previous bash installation script did not display any error messages. I can start from scratch (re-image microSD card with RPi imager for RPi4 approved OS - Bookworm 64-bit) and then run the bash installation script. Do you recommend this approach or would you prefer that I choose the Bookworm Lite OS 32-bit from RPi Imager? I’ll just follow your further instructions if you don’t mind. I understand that there is no need for 64-bit OS with Anthias but I just wanted to try it out anyway. Thanks.


Hi @baqwas, The 64-bit OS will work fine, can you try with the 64-bit lite version and see if there are any errors?

Also, can you confirm if there is any error on CLI while installing the script?

Hi Baqwas,
I had this same issue, to resolve it I used this image:
I believe this has something to do with Python on the latest RPi OSs.
Let me know if this gets you anywhere!

Followed your advice and applied the bash installation script on RPi4 that had a fresh installation of RPi Bookworm 64-bit Lite OS.

No error message appeared on the console during the installation. I did request the upgrade and rebooted appropriately. I can SSH to the installation. Furthermore, I do have keyboard/mouse/display connected directly. The display (after reboot) stops at the console login prompt.

Could you please direct me to some tutorial(s) that I should read and practice without bothering others with newbie questions? Thanks.


Thanks, @jpr. I’ll look into this shortly.


Working on your suggestion right now! Thanks again.


Nope, Bullseye (your image link) didn’t work either. Did request full upgrade and reboot.

Two points that I noticed:

  • The script wanted a response for “manage network” by Anthias server. I’ve tried both options (even though personally I wouldn’t want Anthias server to manage the network) just to get started.

  • References to ansible. Not that the Anthias server would mess up my existing Ansible environment.

Any further suggestions? Thanks.


Hello @salmanfarisvp,

I seem to have issues with the bash installation script (that I overlooked in my initial inquiry owing to my haste). I see some of these messages when running:

$ bash <(curl -sL https://install-anthias.srly.io)

Here are some extracts that lead me to believe that the installation script is not working for me on RPi4 with RPi OS (Bookworm) 64-bit Desktop and Lite as well as Bullseye 64-bit:

+ sudo pip install cryptography==38.0.2
Traceback (most recent call last):
AttributeError: module 'lib' has no attribute 'X509_V_FLAG_CB_ISSUER_CHECK'
+ sudo pip install ansible-core==2.12
Traceback (most recent call last):

It seems nothing was installed! The screenly subfolder has nothing under it!!

I understand that you are busy but perhaps you could spare a few lines to set me in the right direction. Thanks.


Hi @baqwas I tried to reproduce the error and looks like there is an issue when selecting the Network manager and system full-upgrade. So could you please select NO for the System upgrade and Network manager and let me know?


I can continue to SSH as before but cannot HTTP from remote client (as before).

Here is the iteration based on your last recommendation (apologies for the long list but I didn’t know what was the best set of snippets that I could send):

Raspbian GNU/Linux 11 (bullseye) (via RPi Imager 2023-12-05 image)
6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux
Raspberry Pi 4 Model B Rev 1.5

please select NO for the System upgrade and Network manager and let me know?

Confirming as affirmative.

Partial console output 1:

All packages are up to date.

+ sudo apt-get install -y --no-install-recommends git libffi-dev libssl-dev python3 python3-dev python3-pip whois

Reading package lists... Done

Building dependency tree... Done

Reading state information... Done

git is already the newest version (1:2.30.2-1+deb11u2).

python3 is already the newest version (3.9.2-3).

python3 set to manually installed.

python3-dev is already the newest version (3.9.2-3).

python3-dev set to manually installed.

python3-pip is already the newest version (20.3.4-4+rpt1+deb11u1).

The following package was automatically installed and is no longer required:


Use 'sudo apt autoremove' to remove it.

Suggested packages:


The following NEW packages will be installed:

libffi-dev libssl-dev whois

0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.

Partial console output 2:

Attempting uninstall: cryptography
    Found existing installation: cryptography 3.3.2
    Not uninstalling cryptography at /usr/lib/python3/dist-packages, outside environment /usr
    Can't uninstall 'cryptography'. No files were found to uninstall.
Successfully installed cffi-1.16.0 cryptography-38.0.2 pycparser-2.21

Partial console output 3 (some overlap with 2):

Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting cryptography==38.0.2
  Downloading https://www.piwheels.org/simple/cryptography/cryptography-38.0.2-cp39-cp39-linux_armv7l.whl (2.5 MB)
     |████████████████████████████████| 2.5 MB 229 kB/s 
WARNING: Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ProtocolError('Connection aborted.', RemoteDisconnected('Remote end closed connection without response'))': /simple/cffi/
Collecting cffi>=1.12
  Downloading https://www.piwheels.org/simple/cffi/cffi-1.16.0-cp39-cp39-linux_armv7l.whl (367 kB)
     |████████████████████████████████| 367 kB 228 kB/s 
Collecting pycparser
  Downloading https://www.piwheels.org/simple/pycparser/pycparser-2.21-py2.py3-none-any.whl (119 kB)
     |████████████████████████████████| 119 kB 10.5 MB/s 
WARNING: The candidate selected for download or install is a yanked version: 'cryptography' candidate (version 38.0.2 at https://www.piwheels.org/simple/cryptography/cryptography-38.0.2-cp39-cp39-linux_armv7l.whl#sha256=07f8ddebc9d0cbd159c1b6bada223389b1dcab9b10fa9f01178e7309224b6f5f (from https://www.piwheels.org/simple/cryptography/) (requires-python:>=3.6))
Reason for being yanked: <none given>
Installing collected packages: pycparser, cffi, cryptography
  Attempting uninstall: cryptography
    Found existing installation: cryptography 3.3.2
    Not uninstalling cryptography at /usr/lib/python3/dist-packages, outside environment /usr
    Can't uninstall 'cryptography'. No files were found to uninstall.
Successfully installed cffi-1.16.0 cryptography-38.0.2 pycparser-2.21
+ sudo pip install ansible-core==2.12
Traceback (most recent call last):
  File "/usr/bin/pip", line 33, in <module>
    sys.exit(load_entry_point('pip==20.3.4', 'console_scripts', 'pip')())
  File "/usr/bin/pip", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 790, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3/dist-packages/pip/_internal/cli/main.py", line 10, in <module>
    from pip._internal.cli.autocompletion import autocomplete
  File "/usr/lib/python3/dist-packages/pip/_internal/cli/autocompletion.py", line 9, in <module>
    from pip._internal.cli.main_parser import create_main_parser
  File "/usr/lib/python3/dist-packages/pip/_internal/cli/main_parser.py", line 7, in <module>
    from pip._internal.cli import cmdoptions
  File "/usr/lib/python3/dist-packages/pip/_internal/cli/cmdoptions.py", line 23, in <module>
    from pip._vendor.packaging.utils import canonicalize_name
  File "/usr/lib/python3/dist-packages/pip/_vendor/__init__.py", line 94, in <module>
  File "/usr/lib/python3/dist-packages/pip/_vendor/__init__.py", line 36, in vendored
    __import__(modulename, globals(), locals(), level=0)
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 664, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 627, in _load_backward_compatible
  File "<frozen zipimport>", line 259, in load_module
  File "/usr/share/python-wheels/urllib3-1.26.5-py2.py3-none-any.whl/urllib3/contrib/pyopenssl.py", line 50, in <module>
  File "/usr/lib/python3/dist-packages/OpenSSL/__init__.py", line 8, in <module>
    from OpenSSL import crypto, SSL
  File "/usr/lib/python3/dist-packages/OpenSSL/crypto.py", line 1556, in <module>
    class X509StoreFlags(object):
  File "/usr/lib/python3/dist-packages/OpenSSL/crypto.py", line 1577, in X509StoreFlags
AttributeError: module 'lib' has no attribute 'X509_V_FLAG_CB_ISSUER_CHECK'
+ sudo -u chowkidar ansible localhost -m git -a 'repo=https://github.com/screenly/anthias.git dest=/home/chowkidar/screenly version=master force=no'
sudo: ansible: command not found
+ cd /home/chowkidar/screenly/ansible
/dev/fd/63: line 190: cd: /home/chowkidar/screenly/ansible: No such file or directory
+ sudo -E -u chowkidar ansible-playbook site.yml --skip-tags system-upgrade
sudo: ansible-playbook: command not found
+ sudo -u chowkidar /home/chowkidar/screenly/bin/upgrade_containers.sh
sudo: /home/chowkidar/screenly/bin/upgrade_containers.sh: command not found
+ sudo apt-get autoclean

Key observations:

  • More packages installed with tell-tale Debian text progress bar as feedback
  • Screenly folder under /home/user is empty (as previously)
  • SSH access persists but still no HTTP access from remote

Thanks for all your guidance and assistance. Apologies if you feel that I have posted redundantly.

FWIW, the Anthias (pi4) image via RPi Imager does not enable SSH (my experience) or customize credentials (that I always do once RPi Imager was upgraded). There is no DHCP lease in the LAN for raspberrypi.local or raspberrypi. and the attached HDMI display has no signal.

I am simply seeking very, very elementary startup assistance - purely for self-paced learning. Thanks again for your understanding.


New Bookworm support is ongoing and you can find the PR here https://github.com/Screenly/Anthias/pull/1836.

I see the Image from the RPi image is too old and it’s using the old Anthias on top of the Balena OS so no SSH option is available.

I will investigate further and update, I checked the same setup with RPI 3B and it is working fine for me, I will try with 4B and update.

Thank you for your detailed comment and assistance.