Screenly Forum

Setting resolution for a single webpage asset

I have a single webpage asset that does not scale to our 4k screen, as it has been hard coded to 1080p (for a myriad of reason that I don’t want to get into. It will be resolved eventually by the web team). Is there a way to tell that specific asset to display at 1080, while the rest are at 4k? Or to force it to display that asset at (not sure if the math is correct) say 200%? Thanks!

as far as I know the adding of an asset does not allow for manipulation of the actual view of page, since it is just fetching a URL… you would need to change your code (CSS/HTML/JavaScript) on the actual page you are adding, and set the zoom variable you desire as default…

But… if you want to test something out which controls the zoom of ALL the assets because it is a change on the actual uzbl browser that screenly uses, you can change the setting here:

sudo nano ./.config/uzbl/config-screenly

and underneath the “set on_event…”
add this line:
set zoom_level = 1.5
pretty straightforward what it does… 1.5x zoom of the page loaded…
the problem would be that this would mess up every other page by also zooming in those pages to this size… so this is why i think it is best you edit the code on the webpage itself rather than on a browser…

Thanks for the quick reply! That’s what I was thinking, but I wanted to be sure. That will work out for the best anyway as the page is due for a facelift. We will just add that task to the web team’s list. Thanks!

4K support isn’t supported yet in Screenly officially. It may work, but we haven’t tested it. It might work for web and images, but will not work for videos due to a known limitation in omxplayer. We’re happy to take contributions towards getting 4K support working however.

Hello!
can i use same logic to set window position and size?
According to UZBL Documentation
geometry: Geometry and position of the Uzbl window. Format is
widthxheight+x-offset+y-offset

I tried this way but I didn’t get success:
set geometry = 1280x740+0+0
In the execution of my videos I was able to change resolution and position by changing my viewer.py file in the following lines

  `  def view_video** (uri, duration):`

    logging.debug( **'Displaying video %s for %s '** , uri, duration)

    **if** arch **in** ( **'armv6l'** , **'armv7l'** ):

    player_args = [ **'omxplayer'** , **'--vol'** , **'-6000'** , uri]

    player_kwargs = { **'o'** : settings[ **'audio_output'** ], **'_bg'** : True, **'_ok_code'** : [0, 124], **'win'** : **'0 0 1280 720'** }

    **else** :

    player_args = [ **'mplayer'** , uri, **'-nosound'** ]

    player_kwargs = { **'_bg'** : True, **'_ok_code'** : [0, 124]}

I need the web pages to be the same size.

thank you!

I dont think you can change the size of the uzbl i believe because xorg manages the the policy for that, i dont understand why you would want to change the resolution of the uzbl and not just the resolution of the entire pi using raspi-config… can you explain why you are trying to change the uzbl resolution?

Hello!
thanks for the feedback, which uses a part of the tv to display a password caller. Service queue management system.


this black region, and where the screenly content is.

How are you going to display screenly uzbl content on the black part while at the same time the service queue management system unless that is part of the TV that is separate input?
What I mean is, if you add screenly asset of example website, and you make the browser small to fit in that black area, how are you loading the service queue system info? is that also from an asset? because you cant display two assets into one… so you could edit the actual HTML of the asset so that with maybe iframe you can put something to display in that black area while the service queue management system will always be the same, and then screenly assets will just load up different HTML pages with iframes that call up different assets…

Hello!
This html of the queue system, works in the chromium-browser, I was able to reduce the size of the omx Player by configuring the file viewer.py

player_kwargs = {‘o’: settings [‘audio_output’], ‘_bg’: True, ‘_ok_code’: [0, 124], ‘win’: ‘0 0 1280 720’}, wanted uzbl to stay in the same configuration .

Oh I see… since the window manager dont really force any size, then on the viewer.py you would need to pass the --geometry settings as you pointed out, I also tried setting those on ./.config/uzbl/config-screenly without any success, this means it would need to be passed on as the browser is being executed based on the CLI commands how uzbl wants…
so like you mentioned before, this command /usr/bin/uzbl-core --geometry=1280x740+0+0
would need to be passed onto the arguments… I did it and it does resize the uzbl window…