Video - Current url is null

Pictures work fine, but video wont work. Tried both MP4 and MOV.

anthias-viewer Generating asset-list…
anthias-viewer Showing asset video.mov (video)
anthias-viewer Current url is null

Anyone experience the same?

@Nick,

  • I haven’t experience the issue recently, at least on my Pi 4.
  • Have you tried to use other MP4 or mod videos?
  • You can make use of ffprobe to check the MIME-type of a file (for instance H.264).
  • Can you provide details about your environment? (Use the following items as guide.)
    • Raspberry Pi Hardware Version (and max memory capacity)
    • Installation method
    • OS

Thanks.

The solution to my problem was changing from vc4-kms-v3d to vc4-fkms-v3d

@Nick, thanks for the info. Can you provide details about your environment (at least the Pi hardware version and the OS version Anthias is running in)? (so that necessary adjustments can be made to the installer script).

TYPE: Raspberry Pi 4 (using 64bit OS)
HOST OS VERSION: balenaOS 5.2.8

1 Like

Thanks, @Nick. As of now, if you’re deploying Anthias to your own Balena fleet, some settings should be made manually, like the one that you’ve mentioned (setting dtoverlay to vc4-fkms-v3d),

The automation of setting that option is not yet implemented, but contributions are welcomed.

Ok where can I find this information? Couldn’t find anything regarding this setting. It did set vc4-kms-v3d.