Screenly Forum

Does Screenly work on the Raspberry Pi 4?

I followed instructions:

  1. In the files /etc/apt/sources.list and /etc/apt/sources.list.d/raspi.list , change every use of the word “stretch” to “buster”.
  2. In a terminal,

sudo apt update

and then

sudo apt dist-upgrade

  1. Wait for the upgrade to complete, answering ‘yes’ to any prompt. There may also be a point at which the install pauses while a page of information is shown on the screen – hold the ‘space’ key to scroll through all of this and then hit ‘q’ to continue.
  2. The update will take anywhere from half an hour to several hours, depending on your network speed. When it completes, reboot your Raspberry Pi.
  3. When the Pi has rebooted, launch ‘Appearance Settings’ from the main menu, go to the ‘Defaults’ tab, and press whichever ‘Set Defaults’ button is appropriate for your screen size in order to load the new UI theme.
  4. Buster will have installed several new applications which we do not support. To remove these, open a terminal window and

sudo apt purge timidity lxmusic gnome-disk-utility deluge-gtk evince wicd wicd-gtk clipit usermode gucharmap gnome-system-tools pavucontrol

Works fine on 16gb Sandinsk Ultra SD card.

Hi, im trying Rpi 4 with Screenly and i’m getting this error which i’m not getting on RPI 3b+ with same versions.
I cannot add any video, no matter which extension, codec, etc. I can add images.
Any idea?

06.05.20 11:48:43 (-0300) Traceback (most recent call last):
06.05.20 11:48:43 (-0300) File “server.py”, line 690, in api_view
06.05.20 11:48:43 (-0300) return view(*args, **kwargs)
06.05.20 11:48:43 (-0300) File “/usr/local/lib/python2.7/dist-packages/flask_restful_swagger_2/swagger.py”, line 219, in inner
06.05.20 11:48:43 (-0300) return f(self, *args, **kwargs)
06.05.20 11:48:43 (-0300) File “server.py”, line 1019, in post
06.05.20 11:48:43 (-0300) asset = prepare_asset_v1_2(request_environ, unique_name=True)
06.05.20 11:48:43 (-0300) File “server.py”, line 553, in prepare_asset_v1_2
06.05.20 11:48:43 (-0300) asset[‘duration’] = int(get_video_duration(uri).total_seconds())
06.05.20 11:48:43 (-0300) File “/data/screenly/lib/utils.py”, line 184, in get_video_duration
06.05.20 11:48:43 (-0300) run_player = ffprobe(’-i’, file, _err_to_out=True)
06.05.20 11:48:43 (-0300) NameError: global name ‘ffprobe’ is not defined

1 Like

do you have ffmpeg package installed?
dpkg -l | grep -i ffmpeg

i’m sure there is some package situation going on… does the rpi4 and rpi3 have the same version of raspbian?

Could anyone port screenly on Raspberry pi 4 successfully?

I have the same issue, I tried writing OSE image from sprint 10.1 with balena Etcher and splash screen did not show up…

then tried option 2 with NOOBS installation and there was no Option available on installation screen for screenly…

at the end, I tried really DIY optine 3 and installed raspbian os full latest release and then with the command run bash and the script (bash <(curl -sL https://www.screenly.io/install-ose.sh)), tried answering questions with different NO and Yes combination installation and it did not work either…

I really need to have screenly on Rpi4, any suggestion what should I do? or any work around?
When the fix will be available? kindly ask contributor to help us;
otherwise, I have no choice except finding another solution and I think there is no better free on-premise solution better than screenly

During package installation I get this Error…
rpi4 screenly-error
Hardware: 64 GB microSDcard
OS: 2020-08-20-raspios-buster-armhf-full
Screenly: sprint 10.1—2020-07-17-Screenly-OSE.zip

I also checked check-sum of the downloaded file, it was not corrupt.

@docent31
could you please share with us working image that installed on ur rPi4?
I need it badly for my project. I tried all Options and still not working and do not have rPi3 to test ur solution…for rPi4 it need buster OS…

tnx in advance!