Transition pause black screen between mp4s

Hi all,

I’ve done a fresh install of Anthias on a pi 3b installing raspian bullseye OS first then Anthias as per instructions and all seems to work fine. But I have a problem with transitions between media, when it’s the turn of an mp4 file there’s almost a 7 second gap of black screen, then the MP4 plays, then the same 7 second black screen then the next media. If load for example jpeg’s and the next media is a jpg, there’s no gap between but whenever an mp4 loads the same thing happens. I’ve tried multiple mp4s and get the same problem each time. Mp4s are in 1080.

This happens if it’s transitioning from a JPEG to an mp4, or from an mp4 to an mp4, or from an mp4 to a jpg and the same when transitioning out from an mp4 to the next media.

The mp4s play fine once they start, it’s just the black screen ‘pause’ issue. Does anyone have any ideas??

As a total side question not at all related, is it possible to have a ‘ticker tape’ at the bottom of the screen in Anthias?

I’ve tried this on my Pi 3 recently, and I also experience the same issue when playing .mp4 files. I’ll try to replicate the issue again so that I can take a better look on what the root cause is. It might have something to do with the viewer (

For details about what the viewer is and what it does, you can take a look at Anthias’ Developer documentation.

Has anyone resolved this?

@donbucknall Are you still having the issues? can you use the latest version of the Anthias and check please.

@salmanfarisvp I will check tomorrow but it was a fresh install so I assume it was the latest.

What I can see it is the latest.

also see Black screen between videos on Raspberry Pi 3B using it on Raspberry Pi OS 64 Bit Lite · Issue #1851 · Screenly/Anthias · GitHub

If it helps, I have the same thing happen to my Pi 4B after updating last week. I had first installed Anthias in December (before Dec 21). Everything was great. Then I saw there was an update available, but didn’t bother to update until last week. When I updated the pause black screen started. It’s about 5 seconds for me.